Product Info

Mandatory Software Update

An update that resolves the SSL/TLS error when attempting to use ShipWorks is available on our download page. This error is affecting all users and is a mandatory update. If you need assistance updating your software, please watch this tutorial video. Why is the update necessary?  A team at Google discovered a vulnerability in SSL version 3.0 […]

Read More arrow